CMake 3.6.0 or higher is required.  You are running version 3.5.1

Call Stack (most recent call first):

  /usr/share/cmake-3.5/Modules/CMakeDetermineSystem.cmake:98 (include)

  CMakeLists.txt:6 (project)



CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage

CMake Error: CMAKE_C_COMPILER not set, after EnableLanguage

-- Configuring incomplete, errors occurred!

다음과 같은 에러가 발생했다면


CMAKE를 업그레이드 해보자


우선 기본의 CMake 버전 확인

$ cmake --version



이제 아래 링크에 가서 최신 버전을 다운받자

CMAKE 다운로드 사이트  ======>   https://cmake.org/download/



어떤 파일을 다운받는지에 따라 설치 방법이 다른데

cmake-3.10.2.tar.gz로 설치해보자


$ tar -zxvf cmake-3.10.2.tar.gz


그리고

$ cd cmake-3.10.2

$ ./bootstrap

$ make

$ sudo make install


설치하는데 10분 정도 소요된다.

설치가 끝났는데 버전이 확인되지 않는다면
터미널을 종료했다 다시 시작

끝!





Posted by 리 파워온 트랙백 0 : 댓글 0

댓글을 달아 주세요